2011-03-23

libmygpo-qt 1.0.2 released

Stefan from the libmygpo-qt project has just released version 1.0.2 of the Qt/C++ gpodder.net client library. Since the inclusion into Amarok 2.4.1 beta, interest in the library has grown, and packages have been created for different distributions. This release incorporates the feedback that the libmygpo-qt team has received based on these packaging efforts.

Source download: libmygpo-qt.1.0.2.tar.gz
md5sum: 6f88444c82e9840638ec16e366457dd7
sha1sum: e1b2b2fe3bf036c2f7753b0c514982e0583871d1

The licensing was a bit unclear, and has been clarified with this release: libmygpo-qt is licensed under the terms of the GNU LGPL v2.1 or later. Here is a short ChangeLog from the announcement:
  • Changed .so version scheme (again - but now it's final; thanks to "eean" for input)
  • Eliminated some compiler warnings in the code
  • Cleaned up the build system to only install public/required headers
  • Avoid or remove warnings from the build system
  • Updated README file
Thanks to Stefan and the libmygpo-qt team for keeping this nice and useful Qt library up-to-date. We're happy to see the gpodder.net support in Amarok being well received by the community :)

No comments:

Post a Comment

Comments are moderated. Not all comments will be published. Feel free to post replies on your own blog if your comment is not published here.

Post a Comment