gPodder 3.2.1 bugfix release for N9 users

This is a quick fix-up for bug 1627, which has affected several N9 users. gPodder 3.2.1 is the same as 3.2.0, but with a fix in the packaging (postinst) that will make sure that installation and symlinking (optification) works properly, even if leftover files from previous gPodder installations are in place.

tl;dr: gPodder 3.2.1 will appear on your N9 as an update soon (for both AFM and Nokia Store users), and it will fix your startup problems. A temporary fix is also available as .deb for all users who can't wait ;)

Also, if you are a N9 user and your 3.2.0 update worked fine, you can ignore this (the bug didn't affect all users) - you are affected by this bug if after installation your gPodder app does not start at all.

For all other platforms, 3.2.0 is the latest version, and there will never be a "3.2.1" release to avoid confusion (we'll simply bump the next official release to a higher number to get all platforms back in sync). The version bump is because Nokia Store uploads require "x.y.z" version numbers, and don't support Debian package revisions ("x.y.z-r"), which would really be what we want to have here, since it's really just a packaging change (for those not familiar with Debian packaging: "3.2.0-1" would be the first Debian package revision, and if the packaging changes without a new upstream version, the second revision would be called "3.2.0-2", so think of "3.2.0 for N9" as "3.2.0-1" and think of "3.2.1 for N9" as "3.2.0-2" - confused yet? ;).

Some background info: Since the 3.1.2 release (not to be confused with 3.2.1 ;), gPodder for the N9 installs into /opt, and then symlinks itself into /usr where appropriate, whereas older versions simply installed into /usr. The whole optification problem has quite some history (it started with Maemo 5 and lack of free space on the root partition), but isn't relevant to the N9 anymore (there's enough space on rootfs now). Still, Nokia Store QA has a rule that says that most files (apart from some exceptions) have to go into /opt. For 3.1.2 (again, that's not the same as 3.2.1), I therefore made postinst/prerm scripts that link files installed from /opt into /usr (basically what maemo-optify did back in the day, but Harmattan SDK doesn't have maemo-optify anymore, and on the AFM OBS, I can't just install build-dependencies like that). The symlinking failed when leftover files were sitting in /usr at installation time. The details on what the problem was can be found in bug 1627 - thanks to all who reported the problem, and a special thanks to Reiner for taking the time to investigate the problem (I personally never experienced this bug on my own N9, otherwise I would have had fixed it before the release ;).


gPodder 3.2.0 "The Great Radish Famine" released

We've been on a short summer break the last two months, and have waited to release this version until we got Flattr support and MP3 player device sync back into mainline gPodder. This means that packagers can now start packaging gPodder 3 for their distributions if they have been keeping back because of the device sync features. The device sync patches have been ported from gPodder 2.x by Joseph Wickremasinghe and the Flattr support was mostly implemented by Bernd Schlapsi - thanks to both of them for the great support! Other fixes:
  • QML UI: Show cover art in "All episodes" (bug 1602)
  • Add "on_channel_context_menu" (patch by Nick Stevens)
  • MP3 player device sync support (bug 1579, by Joseph Wickremasinghe)
  • Threading: Use util.run_in_background to spawn threads
  • QML UI: Set title bar text for multi-select sheet
  • QML UI: Scroll episode list when opening last item
  • Gtk UI: Initial hack for embedded shownotes display
  • CLI: Show more of the title when updating feeds
  • Flattr integration (bug 1576, by Bernd Schlapsi)
  • DB schema: Cleaner upgrades, fix column order
  • Updated translations and various bug fixes
As always, a detailed changelog is available at gpodder.org/changelog/3.2.0.

md5sum: 29587ee5d88c9802a862ec41686bdd52
sha1sum: bd363a488338455144f4a994d89b204d62dc69f4
For packages in distributions, see the downloads page.

Thanks to all users who supported the gPodder project by providing bug reports, patches, documentation, feedback or donations / Flattrs.