gPodder 3.0.4 "Weekend Vampire" released

A new release of gPodder is out! In the last two weeks, there have been many improvements that already warrant a new release now (the second one this month). Some of the generic changes:
  • Basic support for Python 3 (needs 2to3, CLI only for now, see README)
  • Various improvements to the episode title prefix elimination
  • Tooling: HTTP authentication test tool (bug 1539)
  • Tooling: New maintenance utility: merge-from-transifex.sh
The text mode interface "gpo" has also received some new features and fixes. More features are planned for upcoming releases to make "gpo" a very good alternative to other command line podcatchers. Here are the changes for this release:
  • New commands for gpodder.net: "search" and "toplist"
  • Show titles in "gpo list" output (bug 1493)
  • "gpo list" now highlights disabled podcasts
  • "gpo webui" will start the Web UI server
  • New manpage with explanations and usage examples
  • Various minor bugfixes and improvements
Most changes from the "harmattan" branch (which contains N9-specific customizations) have been merged into the master branch, reducing the difference between the two branches:
  • Merged code fixes from the "Harmattan" branch
  • QML UI: Use Harmattan Qt Quick Components
  • QML UI: Remove empty menu actions
The translations have also been updated for this release: Danish, Greek, Spanish, French, Galician, German, Hebrew, Italian, Kazakh, Norwegian Bokmål, Portuguese, Russian, Swedish and Turkish. New translations have also been added: Basque and Chinese. Thanks to all our Transifex translators!

Detailed ChangeLog: gpodder.org/changelog/3.0.4

Download: gpodder-3.0.4.tar.gz
md5sum: 747100bd088393a253459211157927d5
sha1sum: 2a70bc049594500ce57d033c406183f667e94cf9

For packages in distributions, see the downloads page.

Please note that the Desktop version of gPodder 3 does not yet contain the MP3 player syncing feature. This is also the reason why the Ubuntu PPA won't be updated to the 3.x releases yet. Users depending on MP3 player syncing are recommended to stay on gPodder 2.20 until we get MP3 player syncing into the 3.x releases. When MP3 player syncing lands in 3.x, we will start updating the Ubuntu PPA again. Ubuntu users not requiring the MP3 player sync feature can use gPodder 3 packages from Debian Experimental in the meantime. See this blog post for more information and add your use cases and offer for volunteering to this wiki page. Thanks for your help!

1 comment:

  1. I'm using this version on ubuntu 11.10 and while there are many areas in which it improved over 2.x line there are also some big problems.

    The new gpodder moved many of my files to unknown folders. Why it interfere in the content of the folders is beyond me. Who the hell thought it was good to add that thing.

    The files that were moved are mostly cuesheets and if those are in other folder then the file (.mp3, .wav, or other) they become useless. My podcasts are mostly EDM (Electronic Dance Music) and I'm downloading cues from cuenation.com to add tracklist and possibility to play tracks from the set. I ask you to reconsider dropping of this stupid behaviour in next version of gpodder or atleast adding option.

    In the old 2.x I could enable autoupdating podcasts on the start of gpodder it would be nice to have it back.

    Besides these two problems the 3.x line is definitely a good update to the one of the best programs that I'm using on Linux.


Comments are moderated. Not all comments will be published. Feel free to post replies on your own blog if your comment is not published here.